Images are not getting unlocked

I checked with my hosting service (BlueHost) and they said that GD has been installed now.

I tried Ctrl+F5 and nothing has changed.

Do you have any caching plugin in your site? Does your host have a caching feature?

Also, you can try unlocking an image from a different device and ISP. Some isps’ proxies cache images and other content for a while.

I use W3 Total Cache plugin.

My patrons also report the image unlocking issue. So, it is from different devices/ ISP.

Also, in the picture, the button “unlock it now” doesn’t work.

If unlock button doesnt work, that would point to a JS issue in your site. You can check if there is any code that breaks JS at your site by hitting F12 key (chrome, firefox) and going to ‘Console’ tab.

If there are an errors there, they will be listed. Any JS error may break the code that allows you to unlock the image.

Additionally, if you use any JS minification/caching through W3 Total Cache or other plugin (Autoptimize etc) then those also may prevent the image unlocker script from working.

The image unlocking code works when an image is embedded inside a post and that post/page is being viewed. If the image is directly viewed, unlock button does not work.

Hitting F12 shows a lot of errors. Sample page is given below. Please have a look.

I also deactivated W3 Total Cache and Autoptimize plugins, and then refreshed using Ctrl+F5, but nothing changed.

Those are generally missing image errors. They should be addressed, but they shouldnt affect the JS.

You can try disabling W3 Total Cache and see if this effects any change.

As I already said, I have disabled W3 Total Cache and Autoptimize plugins. This hasn’t changed anything.

Can you lock a post for $1 and post it in a test post and then link me the url of the test post?

Done.

Can you post that image inside an unlocked post and then link the post. This image is inside an already locked post.

Done.

Hi, please let me know whether anything else needs to be done. Thanks!

Do you have Jetpack installed at your site? Do you have image functions in Performance section of Jetpack active?

Yes, Jetpack is installed, and lazy loading is active.

Ok, i identified this to be related to Jetpack and fixed it. The next version (1.6.2) will tell Jetpack not to cache gated images and it will serve them from your site. This will allow unlocking of images.

Its the regular release time so this will go out soon today. You can just update to 1.6.2 when you see the update in your plugin admin and that should solve your issue.

You can update to 1.6.2 from your plugin admin now.

Thanks for resolving the issue!

1 Like

Is it now okay to re-activate Autoptimize and W3 Total Cache plugins?

It should be ok now. W3 Total Cache is an aggressive caching plugin and it may cause some issues at times, so if you encounter any issue you may try deactivating it to check. Autoptimize also sometimes breaks JS (any JS in the site) so you should be mindful of that as well.

1 Like