401 Unauthorized when making API request with Creator's Access Token

I registered my client with Patreon, and got my creator’s access key. But the following command:

 curl -X GET 'https://www.patreon.com/api/oauth2/v2/campaigns' -H 'Authorization: Bearer TOKENID' -H 'User-Agent: Make'

always returns some version of

{"errors":[{"code":1,"code_name":"Unauthorized","detail":"The server could not verify that you are authorized to access the URL requested. You either supplied the wrong credentials (e.g. a bad password), or your browser doesn't understand how to supply the credentials required.","id":"ea463ad3-8a6d-5fd5-b316-d0642145992e","status":"401","title":"Unauthorized"}]}

I’ve tried refreshing and generating a new token, I’ve tried both v2 and v1 keys against v2 and v1 endpoints to no luck. I’ve tried identity and campaigns endpoints which should be allowed with the creator’s token. I’m using curl because for some reason when I make the request via the app it gets hit with a 403 page with some sort of cloudflare challenge (doesn’t matter what the user-agent is).

I’ve poured over the docs and code from the wp/php plugins. The curl request should essentially be the same. The only difference is I’m directly using the creator’s token instead of an oauth redirect login, which according to several posts here, should work. I am making a fully automated app and thus can’t use a manual login sequence.

So its that the request works with curl, but not your app?

Does not work with either. Interestingly enough it does work with the python library, although by what I can see this should be a valid request via curl.

So it works with your python lib. Then the difference in between what the lib does and curl and your app does must be investigated on your end.