The blocked content is saying my real name!?

This is kinda annoying. I don’t want my real name to be shown here in this page. I already changed my profile name in patreon but it’s still not changing! Please help.

I replied to a similar request at WP org forums. I am c/ping it here, since its applicable:

Soon a patch will go out for this, and it will show your Patreon page name or a custom text which you can enter in the options. This may be today or until midweek next week.

Until then, you can use this small pluginlet:

https://www.dropbox.com/s/3nwmo2pe54eumvx/customizations-for-patreon-wordpress.zip?dl=0

Just open this zip, and put in your name where it says “Type in your name here” and type in what you would want to appear as your page name in place of “Type in what you want to show instead of your name here”.

Then zip the entire folder, upload and activate this updated zip as a plugin. It should replace your name with the text you want.

1.2.7 is out. You can just upgrade to it to fix this problem.

Additionally there is a new option in Patreon settings in WP admin that allows you to type in a custom name.