Images in patron-only posts appear in social previews


#1

See for instance:

I assume that has to do with the Yoast SEO social integrations. Is there some way to work around this on the Patreon plugin side?


#2

If you look in the source of your page you’ll see the following:

<meta property="og:image:secure_url" content="https://manywords.press/wp-content/uploads/2018/05/cannon-dutchman-small.png" />
<meta name="twitter:image" content="http://manywords.press/wp-content/uploads/2018/05/cannon-dutchman-small.png" />

These are the values that are used by third parties (like twitter, facebook, this forum) to retrieve the image that should be displayed in the content preview – which are being set by the Yoast social integrations. Although you could block these completely so that no image shows up in the preview, I would recommend that instead you use the image as an opportunity to sell your Patreon campaign: replace the image with one that indicates it’s hidden for non-patrons, i.e: you blur it, and put a “become a patron to view” type banner over the top.

For the article you’ve linked you would need to change the contents of the http://manywords.press/wp-content/uploads/2018/05/cannon-dutchman-small.png image – although be mindful that some websites (like this one, and twitter, and facebook) cache the image so it wouldn’t apply retroactively, you would need to do this before sharing a new post.

For example (forgive me, I’m no designer):


#3

It turns out there’s a setting for custom images in Yoast SEO I wasn’t aware of. Thanks for the pointer!


#4

Aside from what sam said, the plugin wouldnt be able to hide images in previews, post listings etc since WP uses different functions to process them.

If image feature is turned on and the image is locked, however, it should be able to hide the image in previews or post listings.