Patreon Locking Stopped working: 401 Response :{"error": "invalid_grant"}

Hey all -

Using Patreon Plugin Pro, and as of a few days ago it stopped letting users log in. I deleted and re-created the connection to my Patreon site, and double-checked all the API key credentials and whatnot. My users are getting:

401 Response :{“error”: “invalid_grant”}

When trying to log in. Any ideas?

WP 6.1.1 with PHP 8.1.14
Patreon WordPress 1.8.6 with API v2
Patron Plugin Pro 1.5.4
Patreon Button, Widgets and Plugin 2.1.7

-Ty Christian

Are users receiving any error?

Yes, they’re receiving this:

"Sorry, login aborted due to an API error, - Patreon returned: invalidgrant

Are there any security plugins like Wordfence or any plugin that does redirects or any oAuth plugin at your site? If so, try disabling them and testing it out with a patron account.

No, I don’t have anything like that.

Where are you hosted?

Cloudways. Things were working a week ago, this just happened recently.

You can contact Cloudways support and ask whether they have changed anything on their side, especially implementing any kind of blacklisting or security measures that could block Patreon’s oAuth operations at your site.

I’ve verified there’s nothing that’s changed with the host. Currently, users are no longer getting error messages, they’re just getting kicked back to the “unlock with patreon” screen. Any other ideas? Logs I should check?

You can try force-refreshing your connection:

I’ve already tried that. Any other suggestions?

Just tried (again) deleting and re-creating the connection. I’ve even tried going into Patreon, deleting the API key, removing all the text in the connection details, and re-creating the connection: didn’t work.
I disabled all my plugins except the ones needed to keep the site actually up and running: that didn’t work.
I tried deleting the test user in question from my wordpress users list and logging back in: that didn’t work.
I’m not getting any errors, just getting cycled back to the “unlock with Patreon” page.

Can you send me your Patreon page link via DM?

What version of Patron Pro are you using?

The version is 1.5.4

I’m still getting the same issues. I’ve updated to the latest edition, deleted and re-created my patreon sync, and it’s still not working.
I’m also no longer getting any errors in the “health check” area of the plugin.

I’m locking a page, navigating to it in an incognito browser, logging in as a patron (I created a test patron at $5), clicking “unlock with Patreon” → it goes to Patreon asking me to allow or deny, I click allow → and it cycles back to the same “you must be a member”.

Do you have any caching plugins on your site?

I turned those off, which didn’t change anything. However, I looked into my hosting provider, and they had caching turned on via the backend of the hosting. I switched that off, and things started working again!