[SOLVED] Patreon plug in giving an error when attempting log in, goes to blank page with error text only

Hello there!
My patrons aren’t able to log in or connect at all.

I can’t really view things from a Patron side but in incognito mode I attempted to “log in with Patreon” and this is what appeared:

{“error”:“invalid_request”,“error_description”:“Mismatching redirect URI.”,“state”:“eyJmaW5hbF9yZWRpcmVjdF91cmkiOiJodHRwczpcL1wvd2VyYW5kcmEuYXJ0XC8yMDIwXC8wNVwvMjZcL3Byb2Zlc3Npb25hbC1zaG9vdC1neXBzeS1iZWxseS1kYW5jZXItd2l0aC1hcm1waXQtaGFpci1jb21taXNzaW9uZWQtZnVsbC1zaG9vdCJ9”}

It seems to have no problem going to the check out page to “unlock”, but I can’t view beyond there to know if there are more issues. Right now I just need to either fix this myself or bring it to the attention of developers to get fixed ASAP. One patron in particular is very concerned and unhappy about this and I’d like to avoid unnecessary conflict, hence my urgency. Thank you!

This means that the redirect uri setting in Patreon Settings menu’s Connection tab at your site is different from the redirect uri setting in the app details at Patreon.

This can happen when a user starts from a http:// url, whereas your site url is set as a https:// one. Or vice versa.

First, ensure that the redirect uri setting at ‘Patreon Settings’ menu -> Connection tab at your site matches the setting for the same value in your app details for your site at Patreon:

If that is so, then visit the content url in http:// version, try to unlock. If that does not produce the earlier error, then try visiting the same content url in https:// version, and try unlocking again. If any of these last two tests produces the error, then you are using mixed urls at your site. http:// and https:// at the same time.

In that case, installing a plugin to force all https:// or http:// urls should solve your problem.

Ahhh that’s all I needed to do? Thanks, codebard! I was worried I broke it. It appears to be fixed after changing the uri setting. At least, as far as I can tell on “my end”.

I apologize if I came off in a negative way; I am very new to wordpress/more advanced apps like plugins, so I panicked not knowing how to fix it, especially after having a Patron actively voicing complaints about my new site.

Thank you for the SWIFT reply! If there is a way I can rate you/your service as 5 stars please let me know and I will be happy to do so. :slight_smile:

PS: I figured out how to edit posts, so I changed the title to perhaps be more relevant so any others needing help may find the thread/answer better!

1 Like

You can rate the plugin here at WP org:


I recommend a https:// redirect plugin and setting your site url to https://. This way your urls will always be consistent.And no patron will come from a http:// link via search or other means and then end up with a broken login.