Endless loop - Unlock content

I manage a website that uses this plugin and since updating to the last version (and also, upgrading to the V2 of the API) users have been constantly stuck in a loop.

  • Visit page
  • Click “Unlock Content”
  • Click “Allow” on Patreon permission website
  • User returns to the website but no content is unlocked.


  • Using WPEngine as hosting
  • patreon_nonce is already on the no-cache list.

I got in touch with WPEngine and they could not provide any further details. The patreon_nonce cookie had already been added to the exceptions.

How can I approach this? I’ve already checked connection and it seems good. I actually had to migrate to the APIv2 not too long ago cause of some errors popping on the config log.

Any ideas as to what to request WPEngine in this case? I’ve asked them to stop caching post pages to see if that makes any difference, but doesn’t seem to have worked so far.

After trying to manually refresh the page I’m getting this error now:

Any ideas?

Getting these errors as well on the Patreon Health Check page:

Response code: 401 Response :{"errors":[{"code":1,"code_name":"Unauthorized","detail":"The server could not verify that you are authorized to access the URL requested. You either supplied the wrong credentials (e.g. a bad password), or your browser doesn't understand how to supply the credentials required.","id":"049afcfc-7903-4285-b0d2-b6649d32d6b5","status":"401","title":"Unauthorized"}]}

Response code: 401 Response :{"error": "invalid_grant"}

Things I’ve tried

  • Reconnecting using the wizard = no dice
  • Reconnecting manually = no dice
  • Asking WPEngine to momentarily deactivate cache on the whole site = no dice

edit: This is a repost of issue #105 on Github. I’m posting here to see if I can get a clearer answer as to what might be happening.

Reconnecting using the wizard = no dice
Reconnecting manually = no dice

What errors did you receive when trying those out?

No error whatsoever.

The website connects and Health check says everything is good. But again, patrons can’t unlock content. The website returns a “invalid_grant” error when trying to unlock content.

Have you tested the unlock process with a test patron account you created with a different email? Does it give error for you too?

I’m not the owner of the patreon page, and I have a separate account with a pledge on this specific creator to test these things. It returns the same error “Invalid_grant”.

So just to clarify:

  • I perform the sync to patreon logged into the owner of the page.
  • I log out of patreon, and check Patreon settings on WordPress and everything looks good.
  • I open Chrome, log in into patreon with my normal user account
  • Try to unlock content and the loop begins.

So all patrons receive invalid grant when they attempt to unlock?

Do you have any security or caching plugins at that site? Any plugin that modifies oauth, or redirections?

  1. Yes.
  2. No. I even asked WPEngine to deactivate momentarily the caching of the site (whole site) to see if that solved the issue and it did not. So doesn’t seem to be a cache issue.

Any security plugin or any plugin that modifies oAuth or redirections?


Here’s a list of the plugins currently installed on the website:

Im soon going to provide you with a disposable, reference hosting account with fresh WP installed, where you can try connecting to your Patreon account so that we can see whether the difference in between hosting infra has any effect.I will send a DM when it is available.


When you say Patreon Account, is the one the owner of the website uses to lock content and whatnot, yes?

I meant by connecting the reference WP site to your Patreon creator account and then testing unlocking with a patron account so we can have a frame of reference.

I should have it by tomorrow.