Patron login attempts lead to infinite loop

We’re using Patreon’s WP Login plugin for our site, but whenever any patron tries to sign in they get stuck in an infinite denial loop. They hit a piece of paid content, hit the ‘refresh’ link to unlock it, put in their information, then click ‘allow’ Patreon to connect, and are redirected to the start of the process, where they’re asked to hit ‘refresh’ again. The content never unlocks.

There is a workaround to this: If they hit ‘deny’ instead of ‘allow’ they’re kicked back to the ‘refresh’ stage, but this time if they go through it all again and hit ‘allow’ to connect, it’ll let them login.

The plugins all up to date, it has been working fine for years, this all suddenly started in mid-December. Any help would be greatly appreciated, thank you.

put in their information

There shouldnt be any information asked from them at that point. Even less in the 2nd try.

Do you have any caching plugin at your site? Also, try asking your web host whether there is caching at server side.

I must have explained it wrong, I guess they don’t put in their information. It’s the ‘allow’ loop. This is a known recurring issue here, looking up ‘loop’ brings up a dozen threads with no defining solution. I went through all of them and tried every single suggestion, no luck. It looks like most people just pop back in a week later to say ‘it fixed itself, no idea’ – but it’s been happening on our site for six weeks now. We have tried: Disconnecting/reconnecting Patreon, checking patreon connection settings, deleting/reinstalling plugin, turning off other plugins, turning off caching completely, and we’re waiting on a response from the hosting service. Any other ideas in the meantime?

Ah. Those things generally tend to be caching issues caused by a caching plugin on your site or the web host. Try checking out the caching plugins on your site and also contact your host and ask them whether there is any server-side caching. Especially common cPanel hosts can have very aggressive nginx proxy caches.

We’ve definitely gone through and turned off all caching, to no avail. We’ve asked the host but they weren’t very helpful. Maybe if we can be more specific. We want to tell exactly “turn off nginx proxy caching”?

Your host may or may not be using specifically nginx proxy caching. Different hosts may have different caching schemes. You can try to google to check and see whether your host has any kind of server side caching for the plan that you are using.