Webcomic images not being affected by paywall

Having an issue with images being available despite them being put behind the patreon paywall.

Example test page: http://topazcomics.com/genderslices/109/

I put both the post itself and the image behind the $1 mark but the image is still visible to the public.

I’m using the inkblot theme with the webcomic plugin. Webcomic uses a separate featured image to be used as the ‘comic page’ and it’s called ‘webcomic media’.

But the media being put behind the $1 in the media settings just doesn’t work? Is there a fix for this?

I’m using bluehost to host my wordpress site.

If you normally insert an image into post editor at WP and set it a $ level. does that image get locked?

just checked and the image I’ve put under the $1 in the post itself still shows up to the public.

Have you gone to your Settings -> Permalinks and clicked ‘Save’ to update the permalink rules after installing the plugin?

I have done that yes, and it didn’t change anything.

This seems to be a case which would necessitate a direct look.

If its ok, please prepare an extra WP admin login with a sufficiently complex password. And also, if possible, a ftp user too. If an extra ftp user is not possible, please change the existing user’s pass to something new before letting me know.

When ready, just send them to me at ozgur@c.patreon.com . i’ll look into this directly tomorrow. After we are done with debugging, you should delete extra accounts and change any passwords back.

It is blocked for me.

I had a few other people confirm it was working as well. The only thing that was getting me was that I could see it all on my phone after I’d logged out of both patreon and wordpress. But it looks like it’s only doing that on my phone. So problem solved I suppose!

Not sure if you still have the plugin enabled, but I have no problem seeing your images (comics).

so you can see both the comic images on the page? Hm. I do have the plugin running. I guess I will have to get it looked at then.

Yes, I can see them all without any problem.

Using 2 test posts with random images:


That’s normal post type, with a new image embedded into it and locked.

And below is the custom post type gender slides:


Similarly a new image is inserted and locked.

It does seem to work. And according to the reports above, it sometimes work, sometimes doesnt, which indicates to this having the possibility of being a caching issue.

I didnt see any caching plugins in your WP install. But there may be in your host. Which web host are you using?

@codebard The test post you created at http://topazcomics.com/comic-lock-test/ works for me.

Yes it does.

Also, he seems to be inserting the images to a webcomic box (a custom meta box in the comic post type editor) without locking them.

When any $ level set for those images using media library, locking kicks in.

I did set 109 (my tester page) to a $ lock level though, even before setting it to the webcomic media box. And Xevonin could still see it is my big concern.

I’m using bluehost to host my site and I am using W3 total cache as a caching plugin as someone recommended that to me.

Is it this one?

The relevant comic has $0 set for the level.

hm, I’m not sure what happened there then, it was definitely set at $1 yesterday night. I reset it to be locked.