Webhooks not works


I have 2 patreon accounts. First is only for development. I added url for webhooks and it works fine. I see requests from patreon in logs. It’s ok.

Webmaster did the same for real account (I have no access), I checked by screenshoot, it’s ok.
But when he clicked to “send test” nothing happens. Script add to logs all requests (wrong and correct). But nothing from real account.

I have no any ideas why it not works. Can you advice, what else should I check?


Are both valid and active creator accounts with their pages launched?

Yes, all accounts is approved.
Real account have Pro status. Yes, it’s launched and have few patrons

When you create, update or delete webhooks, do you get any messages?

I got credentials from real account. So I can test more now.

Under dev account webhooks works perfect. I have access to few sites, I tried to send test webhooks to different sites on different servers. No problems, it works.

Under real account I tried to send the same test requests to different sites. It works for any site except my main site.
https://subdomain.my-main-site.com - not works.
https://my-main-site.com - not works.

https://my-second-site.com - works.

https://subdomain.my-main-site.com and https://my-main-site.com on server1
https://my-second-site.com - on server2.

I removed all api clients and webhooks records from dev account (I thought maybe it have issue with duplicated domains in 2 different accounts). The same result.

I have not messages when I create or delete webhooks. I enter URL, click + and see webhook below.
When I click “send test” I see popup. It show me correct url and button “send test”. I click to the button and nothing happens. Not errors, no window with result.

The pattern you describe points to there being some kind of filtering at your main site which prevents webhooks from contacting that main site. This may be your host’s security features, or some firewall acting at any point during the connection.

I thought about firewall. But why it works from dev patreon account?
https://subdomain.my-main-site.com - not works under real account, but the same works under dev account.

Asked server admin to check server logs

Was issue with modsecurity.
Admin added exception and it works!

@codebard, thanks!

1 Like

Youre welcome. You should add all Patreon IPs to whitelist.