Wordpress Plugin integration not working

The Patreon button is showing up on my locked posts. However, when I go to click on it to test it, it is not clickable.

I try to do the set-up wizard and it says that I have invalid parameters even though I copied them directly from the app I created on Patreon.

I’ve created a different app to test it with the same result. I also turned off security features with the exception of the SSL cert.

This is likely a situation in which your site cant contact Patreon due to app details being broken. In this case below procedure can fix things:

1 - Check out https://www.patreon.com/portal/registration/register-clients and delete the app related to your site.

2 - Go to your WP site admini, Patreon Settings menu. Click ‘Connection’ button and empty all fields which you can empty. Then click ‘Save’.

3 - Visit http://yourdomain.com/wp-admin/admin.php?page=patreon_wordpress_setup_wizard&setup_stage=0 page to restart setup wizard.

This should fix it.

That reconnected the site but the button still doesn’t seem to work. Example



Button and links inside post content, which now contains the gated post interface seem unclickable.

This may be something due to a theme or a plugin at your site. Can you activate one of the default WP themes and see if situation changes?

Looks like its the theme. Is there a work around besides just changing the theme?

Now, buttons and links inside post content not working is a major situation. It should not happen for any reason.

At this point contacting theme’s support may provide pointers.