404 Not Found when running WP Patreon Wizard

Attempting to utilize the plugin. Tried wizard and manually connecting. When I select Oauth on wizard page I get a 404.

I am using SSL and redirection to SSL Only. So the request is through port 443 ( shouldn’t matter i think ).
It is an Apache2 Virtual Host

The url is:

I am at a loss. Completely new to this plugin.

Thankyou in advance for any help.

I am still working on this so I am going to add information as I go.

I checked the .htacess and the Patreon Plugin seems to have succesfully modified the file.

What rewrite rules do you see in your htaccess file? Can you c/p the part related to PW?

Also, have you turned image feature on or off before?

Ok, thanks for replying. When you asked for the Rewrite rules, i decided it was time to actually learn about them and I think I found the problem …

Here is my mod_rewrite.

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]

# END WordPress

# BEGIN Patreon WordPress Image Protection
RewriteEngine On
RewriteBase /		
RewriteCond %{REQUEST_FILENAME} (\.png|\.jpg|\.gif|\.jpeg|\.bmp)
RewriteCond %{HTTP_REFERER} !^wp-admin [NC]
RewriteRule ^wp-content/uploads/(.*)$ index.php?patreon_action=serve_patron_only_image&patron_only_image=$1 [QSA,L]
# END Patreon WordPress

If I understand the [L] flag this layout means the Patreon rewrite never occurs. So I changed it putting the Patreon part inside the and before the Wordpress rewrite.

Re-loaded the server , but alas no. Still get not 404 found.

I am not sure what is meant by “Turned Image feature on or off”

Thank you again for helping.

I am confused about the callback url:


There is no file correct? It starts with a “?” and then the value pair. Or am I missing something obvious?

That rule for index.php redirection should only work with non-file, non-directory requests. So image request should pass through.

Turning image feature on or off toggles the second block of rules seen in the file you posted - they are the image rules.

As for 404 - for those rules to take effect, mod_rewrite must be installed and active on your web server. That requires Apache web server.

You should contact your web host and ask whether they support htaccess files.

Ok you got me in the right ridrection. It seems the .htacces in my VirtualHost is not being processed. I just have to determine why.

1 Like

Got it ! Thanks. I had to put My

AllowOveride All

in apache.conf and not the virtual host .conf.

1 Like

Yeah, that would prevent htaccess from working. Good find.