Can't connect production website after testing on staging website

Hi, we installed the plugin (and Patreon Pro) on a staging website to test things out but are now unable to connect on the production website. We disconnected the staging website, and started getting this message:

Screen Shot 2021-07-16 at 12.11.23 PM

We tried refreshing the API credentials and reentering, but the message didn’t go away, and we got this error:

add_post_webhook - API v2 Class - UUID 21c72041-e895-47ff-893c-74fc42fc12ad - Response code: 400 Response :{“errors”:[{“code”:2,“code_name”:“ParameterMissing”,“detail”:“Internal Error.“,”id”:“21c72041-e895-47ff-893c-74fc42fc12ad”,“source”:{“parameter”:“id”},“status”:“400",“title”:“Parameter ‘id’ is missing.“}]}

We tried running the Wizard again, it didn’t work. We tried deleting the app/client and it still doesn’t work. When we try to reconnect we get this:

At that point I followed the suggestion and saved empty credentials, we no longer get the reconnect button.

WP 5.7.2 with PHP
Patreon WordPress 1.7.5 with API v2

You can try this:

Visit this page and delete all apps that appear in the list for those sites:

Then visit your site, and disconnect or empty all details and save just like you did for one.

Then you can connect one of the sites using the setup wizard by clicking 'connect in that site.

For the other site, you will need to create an app manually at the page above, and c/p its details to the connection details at that other site. This is needed because api does not yet support connecting more than one site to Patreon using the setup wizard.

Hi, thanks for your reply!I may ot have explained properly, we only need it on the production site, the staging site was just for testing.

Also, we already removed the apps for the site (the others in the screencap aren’t for the site), but the issue remains. The client ID keeps showing up even after I delete it and save, and I only have a button for connection details, the one for the wizard has disappeared.

I tried deleting the plugin entirely to start over, but the options remained when I reinstalled.

First make sure deleting the apps at the register clients page.

For the plugin settings - if you are deleting that client id in that input box, then saving but still having client id reappear there, then there may be something interfering with saving options at your site. That shouldnt happen.