Content Not Unlocking


#1

Users are connecting their Patreon, but content isn’t unlocking for them. However, if they click ‘deny’ when connecting it, that fixes the issue. Users are also having to reconnect their accounts several times a month.

Also, I’m getting this error after updating to the most recent version.:

Warning: call_user_func_array() expects parameter 1 to be a valid callback, class ‘Patreon_Wordpress’ does not have a method ‘add_privacy_policy_section’ in /home/blindw5/public_html/blindwavellc.com/wp-includes/class-wp-hook.php on line 286


#2

Its quite surprising how you get that error with 1.1.2, which you should be on. (or, 3.0.4 for patron pro’s package).

Are you updated to last version of wordpress? 4.9.6+? That may be a reason.

As for Patreon content not unlocking, please go to your client details at Patreon, and make sure you copy/pasted the correct details to your site and vice versa. Also make sure no token is expired. Refresh expired tokens and re-save to your settings at the plugin admin.


#3

Yes, I’m on 1.1.2 and Wordpress 4.9.6+ and still getting the error.

The other issue was indeed caused by an expired token.

Thanks.


#4

That’s weird. If you can get patreon_wordpress.php under classes/ folder and attach it here or post it to dropbox we could look into it. The function is there in 1.1.2 release on WP repo, thats for sure.


#5

Here is the PHP file. Thanks.

https://drive.google.com/open?id=14JUg5aE3MmVnjOxdPSjQ3Vy67kHDMi4s


#6

Incredibly, that function is commented out in your file.

I suggest deactivating, deleting, and reinstalling/reactivating your plugin. It will fix the problem.


#7

So for the long delay in reply. Will deleting the plugin effect users that currently have their Patreon accounts linked?


#8

Deleting and reinstalling can be done safely. Nothing on your site will get affected.