Image locking feature interfering even when turned OFF

I have the image locking feature turned off and yet it is interfering in the WordPress post editor.

In fact, it is popping up over another action button, in this case the “Return to Dashboard” action.

To reproduce this, open any blog post and just click on any image. Repeat clicking on images in the post. The buttons start appearing.

How do I solve this?

This is in your post editor, or when viewing the post from the front end?

Sorry I didn’t get the question. But the screenshot you see is the post editor, so I guess the former.

Right. Do you use Gutenberg or classic editor?

I use the Gutenberg editor.

This seems to be a bug. Thanks for reporting. Ill check this out and probably issue a fix in the next few releases.

Thank you so much! That’d be great.

1 Like

This is not reproduceable with the Gutenberg included in the latest version of WP. Image toolbar works normally.

Can you post your installation info that you can get at Patreon Settings menu?

Also - do you have any optimizers (Autoptimize etc) or JS caching/optimizing features in your theme etc?

Here is the installation info.

WP 5.5.1 with PHP 7.3.22
Patreon WordPress 1.6.5 with API v2

I’m still seeing the “Patreon image lock” button on images once I click any image, as seen in the screenshot above.

Do you have Autoptimize, or any other optimization plugins that affect JS? Do you have any such feature in your theme?

I don’t have Autoptimize or a similar function in my theme. But here is the list of plugins I have installed if that helps.

Checking the optimization settings of Jetpack may provide some clues. What to look for are any setting/section related to optimization of JavaScript, or caching.

Found this.

It is the default setting for all Jetpack or connections.

Turning off static file load time option may be worth a try.

Tried doing that and opened a bunch of posts, from both the “Calypso” interface as well as the classical one. No change, the Patreon image lock button still appears.

Are you hosted at’s Business plan or higher?

I’m on the Business Plan, yes.

Can you try CTRL+F5 or your o/s equivalent to force refresh of all css and scripts.

If that doesnt work out, you may try disabling the installed Gutenberg plugin if you can and see if changes anything.

I tried disabling the Gutenberg plugin and tried editing a post in private mode (to be completely cache-clear) and the image lock button is still showing up exactly as in the screenshot above. :frowning:

The way to trigger that is to open a post to edit and click on any image. Then the lock button appears, and never goes. The more you click, the more it appears.