Index error Patreon Plugin Wordpress

notice: undefined index: included in /hermes/bosnacweb02/bosnacweb02ap/b1270/ipg.phinmagicnet/phineus/wp-content/plugins/patreon-connect/classes/patreon_wordpress.php on line 1765

Patreon plugin for Wordpress throws this error at the top of every page when active. It’s been updated, reinstalled, nothing seems to work. What’s up with that?

This is not an error but a notice - it shouldnt affect operation of your site in any manner. Notices should be disabled in production sites in any case - you should contact your host about disabling notices/warnings.

This will be fixed in next release (within the week) but for the time being you can just contact your host and get notices/warnings disabled.

Incidentally this doesnt seem reproduceable. Which version of the plugin you are using?

The newest version I downloaded from you guys.

The issue cropped up last year, so I deactivated the plugin and just came back to it this week.

I deactivated all the other plugins, but that didn’t show any change.

Changing the php to false did work, though.

Barry Linck

Can you check and confirm whether your version is 1.5.0?

Yep. I have 1.5.0 installed. Fresh install, from download on Monday, I believe.


This is likely because your tiers were not imported yet. If you are still experiencing this when you turn notices on, you can click the refresh button next to the tiers in post locking metabox in post editor to refresh your tiers.

How do I turn tiers on?

You dont need to turn them on. They normally should be updated when you first install the plugin. And whenever you click refresh in refresh button in post editor’s Patreon metabox.

I don’t have anything that sounds like that.

Barry Linck

Something is amiss with your WP installation - with 1.5.0 you should see the below refresh button.

Chances are that opcache or other caching mechanism at your host may be caching everything including the metabox. You may need to contact your host about it.

Ok, thanks. I’ll check into it. At least it works, for now, with the dollar amount setting.

1 Like