Patreon-Connect Plugin Causing 405 Error

About an hour ago the Patreon-Connect Plugin makes it impossible to get to wp-admin because it results in a 405 error:

The method is not allowed for the requested URL.

One of my users got the 405 when they tried to connect their website and Patreon accounts. I then went in and tried to update the Creator’s Access Token in the Patreon plugin. After that anytime I enable the plugin, the 405 error comes back.

| patron-button-and-widgets-by-codebard | active | none | 2.0.5 |
| patreon-dev-plugin | active | none | 1.0.0 |
| patreon-connect | active | none | 1.2.2 |

-----EDIT - I updated Patreon-Connect to 1.3.2. It doesn’t produce the 405 error anymore, but when I try to connect a user I get:
Sorry. Could not acquire your info from Patreon. Please try again later.

-----Also less pressing but under the locked content no amount is listed as to the tier they must be:

To view this content, you must be a member of [Blind Wave’s Patreon] at or higher tier

-----Ok, Quick Start for Patreon: “We must connect your site to Patreon to enable Patreon features. Please to start the setup wizard” Gives me this error:

We weren’t able to get the go ahead from Patreon while attempting to connect your site. Please wait a minute and try again. If this situation persists.

-----I tried creating a new client using API V2 and that didn’t Work Either.

1 Like

It’s not just the plugin. I’m integrated manually using the PHP library, and it has the same issue.

Even on this developer forum, I can’t log in using my Patreon account.

Just from the timing, I think here’s someone else with the same issue, too:

I had my API URLs starting with Changing it to as documented in the API Reference seems to work.

I assume the URL must have changed at some point, because I built my code based on the API Reference and I doubt I just made up the subdomain, so it must have been mentioned somewhere.

The “Let’s Connect” Button does indeed use the URL starting with, but I don’t know how to change it to use the new URL for Authentication.

This seems to have been due to a hiccup at the API at Patreon, and it seems to have been resolved. I have been able to test and confirm that it works.

Looks good on my end. Thanks!

1 Like