Problem with money conversion

Welcome. Our patrons who pay in pounds can’t access the content because the plugin doesn’t do currency conversion. Example: The post is made for users with a subscription of$ 20, the patron who pays 17 pounds can not get access, although on the site itself patreon can. How to fix it or how to enable currency conversion

Same problem with euro and we also already tried to reconnect the api (delete it and then create new one, then connect to the website). that didn’t help either.

We pushed an update to the api with a fix for this issue 2 days ago. Are your patrons still having this problem? What happens if they try to go through unlock flow by clicking ‘Unlock with Patreon’ again?

Hi, we’ll try to contact someone who had this problem previously and ask them to try again. We’ll report back asap. It’s not necessary to reconnect the api, right?

No, no action on your part is needed.

Okay, so we asked one of the patrons who has this problem and that’s what he told us.


In the end, he was not able to get the access even though he payed enough in euros to get the access on Patreon’s website.

Which plugin version are you using?

I’ve checked the plugins and there is indeed an update available now. We’ve been using version 1.6.8, and now it’s updated to 1.6.9. We’ll ask another patron to try it out and get back as soon as we get an answer from them.

1 Like

We’ve asked the same person and alas the problem still persists.

What is the currency of the patron? And what is the currency of the campaign? Also info on how the content is locked, for what tier or how much and how much the patron pledges would be useful.

The currency of the patron is euro, but we also had reports from patrons from UK (pounds). The currency of the campaign is US dollar. The content that is locked costs 20$ (that’s how much the tier costs too). The patron pledged around 17 euros which is the auto-converted (by Patreon) sum of money when paying for that particular tier. He got access to the 20$ posts on the website itself, but when he’s trying to access the Wordpress page with 20$ requirement, he gets redirected infinitely to the Patreon after pressing the button to authorize his Patreon account.

Do you have Patron Plugin Pro?

Yep, we have these three plugins activated (among some other ones) on our website. The website is only used to provide access to download links, it’s not used to sync or publish any posts from Patreon itself.


And here are the Patreon settings for the locked page. The small detail here is that it’s not possible to remove the “optional” precise amount of the pledge required to get access to the page. It’s filled in automatically when the tier is selected. If we manually set it to 0, then it resets to the tier’s amount after the page is updated.



The settings of the plugin itself.



“Prevent caching of gated content” is set to no? Is there a reason for that?

Not really, it was an attempt to give users the access to the download links for the version of the product that was available at the time of the donation (even after they stop the subscription). I can turn this option off if this might potentially fix the issue.

I’ve turned on the option to prevent caching, but we still got a report from a patron (this time it’s another one who paid with UK pounds) that he can access content on the Patreon, but the button doesn’t work for him (redirects back and forth).

One more note, I’ve noticed that the accounts on our website are successfully created for the people who login via the button. They get a username that looks like this - “patreon_1234567”. So this part works fine.

You can try disabling the caching plugin and seeing if it changes anything for that patron. Also which caching plugin are you using?

Also what happens during redirect back/forth of the patron precisely? Any errors, messages?

We’re using Cloudflare standard caching, and we’ve also used WP Fastest Cache plugin some time in the past, but it’s turned off for a long time now. Also, I think our website guy said that he tried to disable caching already and we got the same results. But I will try to turn off the Cloudflare alltogether and get back with the results (maybe it will help).

Regarding what happens during the redirect, the process looks like this - the patron presses on the button to authorize with the Patreon account, then enters the credentials (if they are not already logged in to Patreon), and then they are redirected to a pledge page that asks them to increase their pledge in order to access the content. No errors or messages.

Fastest Cache has created problems before, it is a very aggressive caching plugin.

Cloudflare caching may have had an effect. Definitely try turning it off for a while and see what happens.

then they are redirected to a pledge page that asks them to increase their pledge in order to access the content

This seems like the patron is entering a custom pledge lower than the tier which the post is gated for, or the amount the post is gated for is lower/different from closest tier. What is the post locked for (tier, or custom amount in advanced settings) and what are your closest tiers (lower and the higher)?

I’ve turned off Cloudflare plugin (and purged the cache prior to that), also completely deactivated the WP Fastest Cache just in case (it was turned off in the settings this whole time). Then (after some time) we’ve asked the one patron that had problems (he uses euro), and we got this message:

The page he is trying to access is locked behind the 20$ pledge and we have a tier for this sum (Cannoneer). The closest tiers are 10$ (Corsair) and 50$ (Pirate Town King). After he upgraded his tier to Cannoneer (20$) he’s now able to access all 20$ content on Patreon, but not the page locked behind the plugin. His pledge is 19 euro (which is the sum suggested by Patreon to get the access to the 20$ content). Other patron pledged 17£ (which again is around 20$+, converted by Patreon itself) and he has the same problem.


The page has the following Patreon settings: