Redirect URI Incorrect

My WP configuration has the admin content under /wp but the site content in root.

The Plugin, after linking, shows the Redirect URI as “” but this should be “” but I am unable to change this.

This is an issue because the /wp version gets a 404, if I take out the /wp from any of the re-directs it then works but I must be able to update it to not use the /wp version. I updated the link on the client, tried reconnecting but no joy.

Any suggestion on this or even a DB table are where I can update it manually?

It needs to point to the Site Address not the WP Address

Yes, in such cases you may delete the app for that WP site from your connected apps here:

And then restart the setup wizard.

I have tried deleting the app several times, re-connecting the app several times, in both the admin console on site and through that link you referred, it has not made a difference.
I noted that when disconnecting the site it shows up incorrect right away and I cannot change it here.

Please can you suggest a fix for this or somewhere it can be updated?

The OAuth client through the setup wizard even points to the incorrect /wp URL… It must point to the Site Address (URL) and not the WordPress Address (URL)!

Taking a second look at the urls in that screenshot, your site url and wp address url seem different.

This seems like a configuration issue at your wp site than anything to do with plugin or api.

The url to wordpress and the site must be the same at your WP configuration.

This is not a configuration issue, this is how we have set the site based on the theme and layout of the sites content. The WP site areas point to /wp where as site content areas point to /
Please can you let me know if there is a way to enable the Patreon plugin to allow this to be changed manually?

Is your home page (site url) static? In any case, site url is used for the api (and identifying your site) so it cannot connect to the api like this.

Ah… Due to our config, the Site URL is set with /wp but the Home URL is setup with /

Is there no way of getting the plugin to point to the Home URL, which is used on site for users, instead of the site URL? Even if you could suggest where I may edit this in the plugin itself?

Conceptually it should be possible, but it should require juggling the site_url parameter inside WP, which is not really advisable.

If this plugin is going to be functioning at wp/ location, then you may try connecting the plugin from that location. If a WP site is installed there, its site url should be wp/ already.

The admin panel operates under /wp but the site pages show under /.
The plugin is obviously setup in the admin panel /wp but the pages and user interaction on the site is through /.

I will look into the configuration more. Just through there would have been a way to manually alter the redirect URI within the plugin as that would resolve this issue completely?

That configuration is pretty unorthodox, and it would create issues with many plugins, not only PW. I strongly recommend that you move the wp install up to the root folder if your actual site interaction is at root folder of your website, instead of leaving wp inside wp/ folder…