Stuck Ongoing post import

Hey there, I have an issue where my patreon plugin is not syncing my posts. It synced a handful, then stopped. I’m attempting to start from scratch with it, but no matter what I do every time I come back to the app it is stuck with “there is an ongoing post import”

I’ve tried changing the sync/publish posts settings to all read “NO”, disconnecting/reconnecting my patreon account, deleting the client on Patreon, deactivated/reactivating the plugin, uninstalling it and reinstalling it. And no matter what, it ALWAYS says “there is an ongoing post import” and whenever I push “Import next batch” it comes back with the error “Failed to get posts from Patreon”

I also paid for the Pro plugin, which I disabled for the time being until I figure out this issue.

I have no idea what to do to make this work, help?

What happens if you click the ‘import next batch’ button at post import section?

I’m having this same issue. When I click the ‘import next batch’ button it says ‘failed to get posts from Patreon’.

As I said in my original post, “whenever I push ‘Import next batch’ it comes back with the error ‘Failed to get posts from Patreon’”

Please provide additional help! I need the post import to work. I’ve tried deactivation and reactivation, deleting and re-installing, updating my API key and nothing is making the posts import. I am receiving the same error as Taylor.

Your sites both may have lost connection to Patreon. Following the below steps in the below tutorial may help:

I have done this already. And I just tried it again. I followed each step exactly, and the issue still persists.
Something I noticed:
Even after I disconnect my Patreon site (by deleting the app api on patreon AND clearing all the connection details field within the patreon wordpress app), it still shows that “there is an ongoing post import” at the bottom of the app settings. Even after I disconnect it.
I’ve also tried completely deactivating and deleting the app from my wordpress plugins, and reinstalling it. No matter what I do, it still says “there is an ongoing post import” at the bottom.

Right, when the import has failed and the site is not be able to contact Patreon, it would show that an import still ongoing.

What happens if you click ‘Import next batch’?

As I’ve said three times now, “whenever I push ‘Import next batch’ it comes back with the error ‘Failed to get posts from Patreon’”
This happens every time.

That points to a potential situation in which Patreon api connection may be prevented by your host, security plugins or any security measure which you may have at your site or host.

Have you contacted your host and asked whether connections to Patreon may be blocked?

Nothing is blocked from my host.

Here is my last error if this helps.

0 days ago

get_posts - API v2 Class - UUID f9020251-fa63-4de4-8d0d-abc6f7eb6d2e - Response code: 400 Response :{“errors”:[{“code”:3,“code_name”:“ParameterInvalid”,“detail”:“Invalid parameter for ‘page[cursor]’: Invalid or expired cursor.”,“id”:“f9020251-fa63-4de4-8d0d-abc6f7eb6d2e”,“source”:{“parameter”:“page[cursor]”},“status”:“400”,“title”:“Invalid value for parameter ‘page[cursor]’.”}]}

Does the cron work at your WP site?

What is the cron? Everything was working initially and then I stopped the import because the imported posts did not include the audio link. I thought if I paused or stopped it I could adjust what info was being pulled in, then realized there are no settings like that and attempted to re-engage the import and it hasn’t worked since.

Cron is the important background process which WP sites run tasks that need to be run in the background.

You can install this particular cron manager/viewer and see the list of cron jobs.

Particularly the status of the cron job that pertains to Patreon post import is important. Try to find out when was the last time it ran.

1.6.9 has just been published and it has a fix which will likely solve that problem for you. Just upgrade and click ‘Import next batch’. It should delete the expired cursor and let import start from scratch.