Unlock WIth Patreon Button not working any more


Had a Patron who tried to login into my content with the Plugin (normal not Pro Plugin). I also verified with my test account. When you click on the “Verify with Patreon” Button you are just transferred to my Patreon Tier Page. Looks to my Patreon as if he had to resubscribe… No authentication going on there.
Anyway, when reloading the content page and then clicking the “refresh” - link under said button, the verify Form pops up and content access works from here after pressing allow. (But said forms should pop up when pressing the button in the first place IMO)

I hope you can verify this bug and fix it. It’s quite confusing.

There shouldnt be any pop ups or new forms when clicking ‘Unlock with Patreon’ buttons in the plugin. Where exactly is that button and form in your page?

Mh, sorry, I guess I let myself get confused by my Patrons complaint and that big button…

I thought the “Unlock with Patreon Button” should open the “Verify Form” where you can press allow to access the content, but I guess it’s just intended for new Patrons. It’s a bit confusing for People already coming from my Patron to the site since the Button is so big and the “refresh”-Link is so small :(.
But I guess everything’s working as intended… So, this can be closed. sorry.
(Though it would be more user-friendly if the Button opened the verification form instead of the Patreon Tier Page for already logged-in Patrons ;))

There shouldnt be any verification form that opens when someone clicks that button. The user should be directed to the Patreon authorization flow to allow/disallow your site or confirm their pledge.

Can you take a screenshot of that verification form and dm it to me from the forum?

Sorry, with “Verify Form” I meant that Allow/Disallow flow.
That Allow/Disallow Flow does not come when I click on the “Verify with Patreon Button” I just get transferred to my Tier site. But, the plot thickens, cause I just tried it out on various posts. And it works as you describe for “normally” locked posts. (There the Allow/Disallow flow comes).

The posts I have a problem with are locked with a very high/expensive Tier.
But they are also locked with a lifetime pledge amount. Now the lifetime amount is fulfilled by my user but the Tier is not. That seems to upset the plugin somehow…

1 Like

1 - You lock a post with tiers
2 - The user starts allow/disallow flow from that post
3 - The user ends up at your Patreon page

Is that correct?

If I lock only with a tier it works as intended:
1.) I lock a Wordpress post with a Tier
2.) The user clicks “Unlock With Patreon” → Allow
3.) The user is correctly on my Wordpress post → All good

But if I lock with lifetime support:
1.) I lock a post with a life-time support fulfilled by the user
2.) The user clicks “Unlock With Patreon” → No allow/disallow flow is started
3.) The user directly lands on my Patreon Tier Page

Do you enter only the lifetime amount when locking the post? Or do you select any tier?

It is also locked with a high-priced Tier that is deactivated on my Patreon so no one can join up with it, as those older posts are meant as an archive that can only be unlocked with life-time support. (If I did not lock it with that Tier I’m assuming everyone could access those posts).

Can patrons access that content if they log in via Patreon using the ‘Login via Patreon’ button?

Not really. Pressing that Button on said content directs them to my Tier site and they are asked to subscribe, even though they already are and fulfill the lifetime support criteria.

However, they can press said button on different content that is only locked by their current Tier and log in like that. Once they are logged in via Patreon they then can also access the lifte-time support-locked content.

Can you DM me a post where this can be observed?