Cannot Connect Wordpress Site to Patreon

I’ve just installed the plugin today and tried to connect the site, but it fails at the OAuth part. After I press allow, the code is not received and I get redirected to the following site:

It also prompts me to re-login into Wordpress (which auto-logins after I press login with

What might be the issue? Thank you!

Can you try again right now and see if this situation persists.

The situation persists; it still redirects me to the aforementioned url. Thanks!

Edit: I tried deactivating Jetpack, but it just shows an additional “Sorry - No authorization code received from Patreon.”

SaltyTank and Codebard, I hope this finds you well.

I ran into the same issue last night. Thus searching the forums for answers/

I tried a few of the options seen in a couple other posts, to no avail.

So, I built a test site in sandbox and applied the plugin and connected, then worked. Curious.

So, let’s try this in production:
I went into the plugin and removed my connections, but also went to and removed my connections.

Logged out of wordpress, logged out of patreon, logged back in respectively, loaded the plugin configuration and ran the connection wizard. I was asked to recreate the oauth.

This just worked for me.

What did NOT work for me, was building a new client api manually and updating the information in the plugin manually. So, what it looks like is the edit function is not working to initiate the handshake, like edit and reconnect. But the “New Start” wizard does still seem to work.

Not a full fix but a duct tape and bandaid solution.

I hope this works for you too!

WP 5.5 PHP MySql 7.2 and running on SSL and Hostgator.

Thanks Nebuleux_LTD for the information! Unfortunately that did not seem to work for me.

I’m getting the same error during both the “New Start” wizard setup and manually updating the information in the plugin. There is one redirection plugin running on my site, but disabling it still got me the same error.

Might end up testing every single plugin to see which one is causing issues, though I’d like to avoid the procedure as much as possible. Thanks again!

@SaltyTank Yes, because there is something interfering with connecting to Patreon api at your site.

You are using business plan at right. If you installed other plugins, one of them may be interfering with api connection. Security plugins like Wordfence are potential causes.

I’m actually using on a server, though I’m not the tech guy who handles it. I do have almost 30 plugins installed, so perhaps one or a few of them are interfering with the API connection. I’ll try and have them tested out.

One question though, if Wordfence is indeed causing the issue, does that mean it has to permanently disabled in order for the Patreon plugin to function? It’s not really ideal to have the security plugin down at all times.

Thanks for helping out! @codebard

The chances of one plugin interfering with api connection is high. From right out of the bat it can be seen that you integrated login to your site. Which also has api components (of

Any plugin that does redirections is also a potential suspect. Or caching. patreon-authorization page must not be cached ever.

If Wordfence is filtering it, you should be able to add some rule to allow it. But you must detect which plugin is interfering first. Disabling/enabling one by one generally does the trick.

I’ve disabled every plugin apart from the Patreon plugin and the error still persists. This is the new error page:

Might it be because I’m still using Wordpress 4.9.9? I’m running out of ideas, but thanks anyways!

Well 4.9.9 is pretty old by now. Upgrading may be wise.

There may be something in your hosting setup that prevents connections to Patreon as well.