Content not being hidden


#1

I have $1 minimum set with the active checkbox checked. The content is NOT being locked.


#2

Do you have pretty permalinks turned on in your WP installation?

Also, check out and make sure that your caching plugin does not cache pages for known users (logged in users etc).


#3

My Permalink settings are set to Day and Name - https://johnlevan.com/2019/01/22/sample-post/

I don’t have a cache plugin installed at all, and can’t find anything in the admin section about cache at all.


#4

Are you getting any error messages?

Also checking if your app credentials and redirect uri match - both at your site, and Patreon.

Also, you may not be using a caching plugin, but your web host may be doing caching at server level. You can put a support ticket and ask your host about that.


#5

I’m not getting any error messages at all. All my Patreon data matches. I’m wondering if it’s a plugin or something that I’m using. I’m actually trying to protect photo galleries with a plugin that was installed by my theme.


#6

It could be.

Do you appear properly logged in, with WP toolbar appearing at the top with your login name etc? (If WP toolbar is turned on for your user).

Some ideas:

  • Check if you are properly logged in to WP
  • Check if WP is not serving you a cached page, due to whatsoever reason.
  • If you are using a CDN, check you are not getting served a cached page from your CDN (Cloudflare etc)

Also if you can take a screenshot of the locking options you used - ie the Patreon Level metabox in your post editor - and post it, it could be helpful.


#7

This is a screenshot of the settings I have on the post itself.

When I am logged in with the wordpress toolbar, everything works as expected.

When I am NOT logged in- IE, I went to a whole different computer that I’ve never logged into Patreon or wordpress on before and it did NOT block the content for me. It let me view the content as though I was logged in.

I am not using any CDN that I am aware of. As far as I can tell - wordpress, jetpack, web host - there is nothing being cached.


#8

Now, this seems to be a custom content situation in which the content you are showing does not go through the_content filter of WordPress.

This kind of situation arises because a plugin or a theme shows some piece of content (gallery, images, or even posts) without applying the_content filter. You cant lock such content by traditional method.

What you would need to do is inserting code below into the place where that gallery is shown in your theme.

It allows you to lock custom content. Just wrap your gallery’s code within the if block explained in the document above, and it will get locked.