Content Not Unlocked Until Edit Pledge


#1

I’m having a lot of users linking their Patreon accounts via Wordpress but the content not unlocking until they go and edit their pledge, then the issue is fixed. Any idea how I can make it so they don’t need to take this extra step of editing their pledge?

Thanks!


#2

It may be due to caching at your site, or their browser cache upon first look. Rarely it can be due to ISP doing some caching on their side.

Trying to reproduce the issue on different browsers on different devices you have (desktop, laptop, mobile) and see if it is reproduce-able in all environments from the perspective of a non logged in user trying to unlock the content may show some pointers.


#3

Do you have any recommended setting for W3 Total Cache for compatibility with the Patreon Plugin?

Is there a cookie that I need to exclude from Caching?


#4

patreon_nonce cookie must be excluded from all caching - in any platform. You may set (and should set, actually) W3 total cache to not cache pages for logged in users.


#5

I’ve excluded patreon_nonce from all caching and have set W3 total caching to not cache logged in users and the issue is still happening.

Also, every week or so users are having to relink their Patreon.


#6

Checking if any of your tokens are expired at Patreon could be helpful.


#7

Already checked that. They are good.


#8

At this stage, disabling w3 total cache and testing to see if any of its convoluted options and settings cause this issue, and also contacting your host to see if they have a site or server level caching ( page or opcode ) implemented, would be helpful.


#9

It happens even when w3 total cache is disabled. I have ngnix on the server, and tried purging the cache, and am still having the issue.


#10

Hi, I have nginx on my server too. Where I can find additional rules for vhost for patreon images lock?

Thank you.


#11

The server is running opcode. Have you successfully tested the plugin with nginx, is there known compatibility issues?


#12

Below is a post with the rules:


#13

Image feature requires the custom nginx rewrite rules posted above to be manually added to your server config. Otherwise image locking wouldnt work.

But this shouldnt cause the issue you experience. You can attempt to clear your opcode and see if it changes things.


#14

Ok, I’ve taken out all caching and the issue is still happening.

Users login to my Wordpress site, click unlock content, click allow and the content is still locked. Several loops through this process seems to finally unlock it. I really need help getting this issue resolved.


#15

Please let us know if this situation still persists.


#16

Same as other threads:

Please delete the existing Patreon WordPress on your site (deactivate first), then upload and activate the below package with oauth error reporting and see if it sheds any light on this issue by showing an error:


#17

Ok, done. Yes, it’s still an issue, I’ll keep an eye out for error messages. Some users have also reported being unauthenticated from Patreon after about 30 minutes or so.

Some people can’t get it to work no matter how many times they try, but they’ll come back in an hour and it’ll work first try.


#18

I don’t know if this is a seperate issue, but a couple users have gotten this message when trying to connect to Patreon:

One user tried to connect again and it worked the second time.

I noticed this user is using an ad blocker. I’m not sure if that has anything to do with any of the issues my users are experiencing. Edit: Nevermind I’ve had it happen to users with no ad blocker.


#19

That is the issue, and that is the error message which is supposed to appear when the ‘issue’ happens.

Its not an issue due to plugin per se, but cloudflare blocking access to the API. That was causing the logins, user creation etc to fail.


#20

Ok. How do we fix it? I’m not using Cloudflare as far as I’m aware, and it says that Patreon.com is blocking it. Does that mean it’s on the Patreon side of things?