Post Locking disabled (Followed Setup Instructions)


#1

I just followed the installation instructions to a T (plugin version 1.0.2 and Wordpress 4.9.4) and the post locking boxes (both for entire site, and on individual posts) are still disabled.

Any other suggestions? (other than setting up client, copying credentials, changing permalinks & refreshing)

Are there any known plug-in incompatibilities, especially with popular plugins? (e.g., Yoast)

Thanks for any guidance.


#2

If patreon-creator-id is not saved, then post locking options will be totally disabled. It means that the plugin was not able to acquire creator id from Patreon using those API credentials.

If you have entered your credentials correctly, all i can think of is that there is something that possibly prevents your website accessing the API. This may be something to do with your host, the firewall on the server or anything similar.

First make sure the credentials are exactly correct and everything is there - no spaces copied at the start or end of any credential, and no issues with special characters not being copy/pasted correctly due to your browser etc.

Then, visit the plugin options page and refresh the page. If the site unlocking option doesnt become available, it means that the plugin is not able to contact Patreon during plugin initialization.

At this point you could contact your host and ask them. Its also possible that aggressive caching (like opcode cache) on host side is preventing the page from showing its recent state and hence option remains locked.


#3

At this point, I’ve 10X checked the credentials, so that’s not it. I’ve also disabled caching (and purged my CDN cache), so I don’t think that’s it.

Might a CDN in general prevent this plug-in from working? (I’m using Cloudflare)

I’ll check with the host to see if they can help. Thanks for the quick response.


#4

Indeed, contact your host, and ask them whether there is anything preventing wordpress from contacting remote hosts. Whether cURL is enabled and so on.


#5

Hi @codebard (and anyone else reading this who experienced a similar issue): the problem was with a mandatory caching plugin (in the mu-plugins directory) I didn’t realized my host had installed.

Secret caching ≠ a happy Patreon plugin installation.

Thanks for you help.


#6

Yeah, that generally happens with WordPress hosts. Good to hear it was fixed.


#7

@killermann - just to be 100% clear: was your issue exclusive to Wordpress mu (aka multi-site) installations hosted on services like WP Engine that have aggressive caching?

What was the solution? Did they uninstall/disable/tweak the “secret” plugin? Could you have done it? Know the name of the plugin?

thanks!


#8

The plugin was called “Endurance Cache” and it was auto-installed by my old host (not WP Engine), and still active when I switched. As many times as I tried to clear that cache, it wouldn’t allow the Patreon Plug-in to connect with the API.

I deleted the plug-in myself and all was good.