Images do not load

Since several updates ago, the plugin is giving me problems with loading images (any image, even those that are not in the Patreon_Protect folder) :persevere:
They simply appear broken, I have to reload the pages several times (and pray) to get the images to load :sob:
But, when I deactivate the patreon plugin, everything goes back to normal :thinking:
Of course I need the plugin active! :scream:
Any ideas?

WP 5.6.2 with PHP 7.4.15
Patreon WordPress 1.7.1 with API v2

patreon_protect and similar folders are no longer being used. Since a long while actually. There shouldnt be any files in such folders.

Your issue is probably that you enabled image locking, but your host doesnt support htaccess files. Or you enabled and then disabled it, but the htaccess change did not take effect. ‘Save’ in Permalinks settings menu can help.

Uhh… “Save” in permalinks has made no difference :cry:

Do you have any other suggestions? :confused:

Even images that are not “image locking” also appear broken. But I insist that when disabling the Patreon Plugin, all images load normally (I would say even faster), so the problem is not from another plugin.

Contacting your host and asking about this may work. Some hosts have different configurations with how .htaccess is implemented (if implemented at all). If htaccess or wherever the rules are being read from at your server, then this would persist.

Good again, I have a simple derivative doubt.

During these days, I have changed the CHMON permissions to the upload folder and files, but it did not solve anything :persevere:
After much searching, finally the Jetpack Plugin (and its “enable site accelerator” option) has made everything to load normally again :heart_eyes: :partying_face:

But now… the locked images are not being unlocked :tired_face:

This problem is precisely queried in this topic, and the solution discussed is “upgrade to version 1.6.2:thinking:

but, I currently have Jetpack version 9.5.1 :scream:

What can I do? Some idea? :confused:

1.6.2 is the plugin version, not jetpack. If jetpack is handling images and caching them, they may be auto-unlocked because plugin may be bypassed.

Hello again, sorry for the inconvenience :persevere:
I have deactivated the “site accelerator” of the jetpack plugin and tried installing some older versions of the Patreon plugin:

  • 1.6.9 and earlier → Everything is fine :heart_eyes: :partying_face:
  • 1.7.0 and later → Broken images :broken_heart: :cry:

I said before that everything works fine with my pictures by deactivating the Patreon plugin, with this test, I think I can say that there is some bug in version 1.7.0

For this moment, I’ll stay on 1.6.9 :sob:

That’s pretty odd. Can you see if there is any error in your site’s error logs?

same issue here I think, please advice and support