Patreon plugin not grabbing emails


#1

I’ve let the plugin register new accounts when patrons connect their patreon account, but seems like the plugin doesn’t grab their emails. i had to manually add the email of each users in order for them to comment on posts, and it seems like there’s no any setting to change this.

also, i have to say that i installed the 1.1.0 version of the upcoming update, and seems like the image locking feature doesn’t work.


#2

Indeed, plugin doesnt save the emails from Patreon users. In the next few releases it will save the users of emails who have their emails verified. Non-verified emails wont be saved still.

1.1.0 is a work in progress (though it will be ready very soon) so it is natural to expect some mishaps. What particular issue do you have with image locking?


#3

it just doesn’t lock any images at all. I’ve done every single step of the instructions and they’re still view able to patrons. Regardless of patreon level of contribution.


#4

Have you gone to Settings -> Permalinks in your WP admin and clicked ‘Save Changes’ to make the htaccess image protection rules active? That is necessary to refresh htaccess rule cache of WP.


#5

I already did that but. still not working.


#6

Ive sent you a dm about this just now.


#7

it just doesn’t lock any images at all. I’ve done every single step of the instructions and they’re still view able to patrons. Regardless of patreon level of contribution.

WordPress doesnt seem to be able to auto-generate rewrite rules on nginx servers. That’s what your web host uses. For that reason not only image locking, but numerous other WP plugins which create htaccess rules would have difficulty in getting to work on nginx servers unless the mod_rewrite rules from apache are translated into nginx rules and put into server (or virtual host) config manually.

Long story short, you can ask your host to put the below nginx configuration directives to your site’s config to test whether this will kickstart image protection.

location / {
  if ($request_filename ~ (\.png|\.jpg|\.gif|\.jpeg|\.bmp)){
    rewrite ^/wp-content/uploads(.*)$ /index.php?patreon_action=serve_patron_only_image&patron_only_image=$1 break;
  }
}

For all accounts and purposes an Apache host is much better for WordPress in that regard.


#8

And how i can do that? should i talk with wordpress support?

another thing i noticed is that seems like the browser doesn’t remember login sessions, and i always need to login every time i open it. maybe because there’s no “remember my session” checkbox?


#9

You should contact whoever is hosting your WordPress website.

To comment on the other point, you would generally not want this functionality since that way you will never have up to date data about your patrons connected to your WordPress website. Not saying it’s impossible to achieve, I would however not recommend it.


#10

I think you are on WordPress.com hosting. I’ll test with WordPress.com soon myself and see what can be done.

WP’s own login with your own WP account, or Logging in with Patreon?

That’s not a problem. The plugin checks for valid patronage (and relevant patron details) on any given page load, once. Staying logged in to WP and Patreon both is not a problem.


#11

i mean, logging with patreon. every time i logging with it, the plugin always request permission to access. then after time passes, the session expires.


#12

Its not the plugin that asks permission for access again, its the way Patreon API works - it requires permission after logging into Patreon.

If your Patreon session is expiring fast, you need to look into why it is happening. That may have something to do with your browser settings.