Plugin not working. Everybody can read the posts


#1

Hi,
I’ve installed the wordpress plugin on my site. My patrons told me it was not working, they couldn’t access the posts.
So I uninstalled the plugin and installed it again. And now it’s not working and everybody can see all the posts.

I don’t know how to fix it. Any help would be much appreciated.

Thank you.


#2

Please check your API credentials in plugin settings, and the credential details at Patreon where you created them.

If any credential is wrong, or any token is listed as ‘expired’ anywhere, the plugin will avoid locking anything.


#3

Thank you. I’ve checked it both in the plugin settings and on patreon. The credentials seem to be right and nothing is listed as expired. What else can I do?


#4

Thats very weird.

If its ok, i would like to investigate this on-site. If so, please create a new admin credential with a complex password and mail it to me at ozgur@c.patreon.com . This admin account should be deleted when debugging is complete.


#5

Laura, if you sent the credentials, i still did not receive them


#6

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)


#7

@laura FYI your email created a new reply on the forum, which means the credentials you’ve provided are now public. You need to immediately log in to your Patreon account and delete the client to expire the credentials because right now anybody can access your Patreon data.

Go here to delete: https://www.patreon.com/portal/registration/register-clients


#8

Thank you very much, Sam!!


#9

Yeah, Laura, please send the login data only through email.

What’s needed is a WP admin account by the way. API credentials would help, but not needed at current stage.


#10

Laura, last 2 emails i sent to your email have been returned by your email provider with “address not found” error.

Aside from that, i made a test post and locked it with $5 level, and its properly locked. Please check it out and let us know.