Posts not syncing to WP

My original import from Patreon to WP worked fine but since then the plugin doesn’t automatically sync new posts on Patreon to WP.

My plug-in health check gives lots of the following errors:

fetch_tiers - API v2 Class - WP error message cURL error 28: Operation timed out after 5001 milliseconds with 0 bytes received

Any help for how to fix this would be greatly appreciated!

Something in your web host may be blocking connections to Patreon. Hence the timeout. You may contact your host with this information.

Thank you for the reply. I have sent the information to my hosting company and they have already said they can’t find a reason for my problem. Specifically they said: ‘I am afraid that since we are not familiar with how exactly the plugin works, I am not quite sure why the errors may have occurred. I checked for possible cues inside the access, error and firewall logs, but I was not able to find any. However, the search could be refined if we know exactly what to check for, e.g. an IP from which a request is made’

There is nothing in the plugin that is particular to connections. It uses standard WP connection functions. wp_remote_post, wp_remote_get.

For IP, they can check any ip that resolves to All such ips should be reachable and not filtered.

Note: Security plugins like Wordfence may cause such situations if configured aggressively.

Thank you for your reply. I passed on your comments. My hosting service support has said:

‘The website uses Cloudflare for its DNS zone and in this case, we can’t really see their actual IP address. In this case, please, ask their support or developers team to provide you with their IP addresses just so we can be sure we are not blocking them.’

I really appreciate any further help you can give!
Best wishes, Simon

Considering how Cloudflare IP addresses change, your hosting will need to account for that. If they are outright filtering Cloudflare IPs, that’s not supportable from our side.

Good luck. I’m still dealing with this and it just doesn’t work.

Thanks. I’ve given up for now. I tried disabling Jetpack, but that doesn’t work. I think I’m just gonna leave it and hope that maybe a future update to the Plug-in solves the issue at some point…

If your host is filtering Cloudflare ips, that cannot be resolved by any means other than changing your host, unfortunately.

There is a hosting project from Codebard to provide Patreon compatible hosting to prevent such problems, but its not available at this point. So you would need to find a host that doesnt filter Cloudflare.

1 Like