Tier locking doesn't work

I have this weird error on my WordPress site where users can access posts restricted to higher pledge levels. For example a $5 tier user can view $20 tier content. How can I fix this?
Thanks for the help.

Have you deleted/updated your tiers since locking that post?

In fact, yes. I’ve recently increased pledge amounts for all of my tiers. But this issue seems to persist not only in posts made before the change, but also in newly created locked posts.

Can you try unpledging and then pledging again with the test account you are using, and see if the situation persists?

I tried, and it didn’t fix the problem. I also tried reinstalling the plugin & issuing new client API key. None of that helped. Another thing I noticed that I think is definitely related to this problem is when I view a locked post with my test account, the plugin says that I’m a VIP user (which I assume is the highest tier) when in fact I’m not. This is strange, because the checkbox next to ‘VIP’ in the user account page for my test account appears unchecked, too.

You have Patron Pro. Please try updating it to latest version and see if this resolves this issue.

Same problem, our $5 users had access to our $10 content after updating to 1.3.4 pro.

We had to revert back to the free version to lock things again.


Codebard… updating to 1.3.4 does not resolve this issue!

Why haven’t you responded to our Support Ticket that we sent a week ago?

Your ticket may have not been processed by the support system after it was updated. What is the ticket id?

I don’t see a ticket ID on it… here’s a screen capture…


Screen Shot 2019-07-12 at 11.48.02 AM.png

Your ticket was updated. Please check it out.