Two issues with imported posts

Hi! I’m a new user of the plugin. I’m looking for help with two issues related to posts imported from Patreon.

  1. All imported posts are dated at the time of import. This drowns out all of my recent WordPress blog posts. Is there any way to have them all import with the time of their creation on Patreon? Or would I have to manually edit all imported posts to achieve that?

  2. In my blog feed, the excerpt for locked posts is a clunky text-only version of the “Unlock with Patreon” button and accompanying text. I like how this code appears in its full form on locked posts. But the text-only version in excerpts doesn’t look professional. It needs a period after “or more”, a period and space after “Unlock with Patreon”, etc. Is there any way to fix this without creating manual excerpts for all of those posts?

Thanks in advance!

1 - If you set the status of imported posts to draft (or anything other than published), then you can edit their dates before publishing them. This is manual, however it should be needed only for importing your already existing posts.

2 - This may be due to your theme - it may be formatting excerpts to text-only. Try checking it with a different theme.

I’ll fix the dates manually then. Thanks.

For the excerpts, I also tried it with the default Twenty Twenty-Two theme and it did the same thing.

The problem seems to be that imported posts don’t have any content in the excerpt field. When I edit an imported post, the excerpt field is blank. So on the blog page, WordPress autogenerates a text-only excerpt for that post based on the start of its main content.

If the plugin doesn’t generate any excerpts for imported posts, then there may be no avoiding this. Does the pro version generate excerpts when it imports posts?

Can you try Twenty Seventeen theme?

Switching to Twenty Seventeen theme worked! So it’s surely a theme issue rather than a plugin issue.

I’ll check in with the help community for my theme. I don’t see any obvious settings to change this excerpt behavior [text-only excerpts]. But maybe they’ll know of a setting or have an alternate solution.

In the meantime, I’ve just turned off excerpts entirely. Imported Patreon posts now display the “To view this content” message properly in the blog feed. This isn’t ideal since I would prefer excerpts, but it works for the time being.

1 Like