Patreon App Sync no longer working

I installed the Patreon plugin and it pulled in all my posts, which was great. I tried a second install, but decided against that and removed the plugin and respective connections. I then created a fresh install of the plugin to my main site, got everything connected, but the sync doesn’t seem to work anymore. I’ve tried to run it 2-3 times and gotten nothing.

I’m NOT running jetpack. It was working great before I tried to add it to another WP subdomain (was in between ideas and ultimately decided not to add a second website to my patreon world).

So how do I kickstart this thing again? It was nice to post one place and have it go to two.

You should make sure that connection of the site to Patreon is fresh. You can try the below guide:

So I got a new import. Then all those posts sat in pending. I cleared them out, but each time I deleted a batch, the plugin threw an error and I had to go into wp-admin again, then repeat the process. Every bulk delete of pending resulted in my admin page not refreshing back.

After clearing out all the pending posts and re-logging in each time I had to delete bulk posts (they’re already posted), the most recent post didn’t show. So I initiate a sync to get the most recent post.

THE MOST RECENT POST didn’t show, but everything else did.

What is up with this plugin? It won’t get the new posts, but when you initiate a sync, it pulls in everything again. DO I just have to make these things sit in “pending” forever, hogging up space on my site?

The plugin is set to import all posts when you start a new import. That’s expected behavior.

If the posts are already found in your site (imported earlier, or have the same title with post at Patreon), they are just updated. If the plugin cant detect that the post exists, it will re-import it.

If the posts are constantly being created and they are the same posts, then the plugin is not able to detect the existence of the post. This would mean that either there is a plugin that interferes with post metas, or you have Redis or another caching method that interferes with meta retrieval or other db operations.

This behavior is not reproducable in a reference test installation and there isnt anybody reporting anything like this at the moment. This points to the possibility that there is some situation with your site setup.

So what you’re telling me is: For posts to not continually be re-imported. OLD posts have to have a place on my site or else it will continue to reimport the 300+ posts every single time I try to manually sync the site? The dates are also always the current date, not the date of the post. I want these old posts gone, but I can’t have them gone, because they re-import when the import process hangs.

In relation to my most recent post not showing, that’s because the title is the same? So if I were to change the title of the post of my most recent WP post, then I should see the most recent post populate?

Here you see 449 posts that are “pending” - All with the date that’s dated to another time-zone. Every single post is now BEFORE my most recent post. If I delete them, it’ll just re-import the next time I have a sync issue.

Is there a way to change the date to something that gets them out of the way? The previous question still exists in terms of if i name something slightly different, will it import? Because it didn’t import this morning, so I created the post manually.

It was almost immediate on first install. it hasn’t worked since the fresh install. Open for resolution that doesn’t involve blaming a paying customer of your pro plugins.

Yes, if you start a full import, for the old posts to not be imported, they must already have been imported. It does not matter whether they stay in draft or unpublished state - the plugin just needs to be able to know that they were imported.

If you start a new import, this is what will happen - all posts get synced.

The date is intentional - it reflects the date of the import of the post into WP, not the original publication date.

Because it didn’t import this morning

Syncing of new posts after one run of post import completes is done differently - they are done through webhooks that contact your site and send the post data. If your host or website prevents these connections in any way (security, load on your server etc), then the syncing of new posts dont work.

So basically:

If you dont want to import old posts, delete all of them and dont start any kind of manual import.

If new posts are not coming in, the site may have lost its webhook - disconnecting the plugin, deleting all plugin data and going through the setup wizard again (including post sync part) should help re-create the webhook.

If you still dont receive new posts after that, a security issue at your site or server can be suspected and must be investigated. I can also look into your account’s webhooks on this side as an added measure.

Open for resolution that doesn’t involve blaming a paying customer of your pro plugins.

The issues i mentioned earlier and in this post are common issues stemming from website setups and host setups. They constitute a significant portion of issues with the plugin, and they cannot be solved without talking about them.

This worked flawlessly until I had tried to add the plugin to a subdomain (which I’ve explained). So whatever webhooks that were calling to the main site worked, so it’s not a security issue with my site.

Upon your step-by-step instructions is what I’ve been doing since. I’ve just posted a test post to my patreon (mattalkonline) - screen shot included

This was updated almost immediately on the first install of your plugin. I’m trying to get the functionality of the plugin back to what it was. I’ve deleted the plugin, followed your step-by-step instructions, done a full re-import manually. I have followed your instructions verbatim.

Next screen shot shows no post coming in. Again, this was essentially immediate. It’s been a number of minutes since I posted on Patreon and took this screen shot.

I don’t believe this to be a security issue. The only thing I haven’t done was remove the plugin manually using FTP. I deleted it via the plugin manager on the WP dashboard.

It’s frustrating to spend money on a plugin (because I bought Pro), have it work. then have it not work when you add it to a second site (following the instructions verbatim), then have it kind of work and not as its intended. What do you need to be able to check on your end?

How did you try to add the plugin to the subdomain? Did you just install another copy of it and tried to connect it to Patreon? After having connected the main site? Are you using multisite?

I don’t believe this to be a security issue

Security plugins and server side security measures work on varying algorithms. You can have a request working without problems for months, only to have it fail after a plugin or server-side security upgrade because the new algorithms match the call’s pattern. So it cannot be ruled out.

It’s frustrating to spend money on a plugin (because I bought Pro)

Sorry to hear that you are experiencing so many problems specific to your setup. However people having with specific setups is not uncommon - every WP site has its own config. If you wish, just post a ticket at so i can refund you and cancel the license.

What do you need to be able to check on your end?

Remove the plugin from your sites (including subdomain), delete the app created for it at the below page, wait a while - (to give opcache enough time to clean its cache if the host has it), then reinstall it tomorrow or later and re-connect it from scratch. Try a test post at Patreon, and let me know if its imported in 15-20 min or not. Then i can check your webhook. If the webhook is legitimately working on this side, there is nothing more that can be done from this side.

Also one important point - if the cron at your WP site is not working, you wont be able to import posts properly.

Checked the cron jobs. Screen shot attached. Seems to be working fine.

Will start the whole process over from scratch, but this time removing all the instances of the plugin from the domains via the FTP AFTER the deletion of the plugins from the plugin manager inside WP.

Left it overnight. Deleted everything. Reinstalled the plugin. Settings were still included. I cleared them. Updated. Then reconnected. It’s run the cron job twice already. There is an existing post. It has not imported. I posted a new test post. It’s run one cron job since. No update. Still have the same amount of posts as I did yesterday.

Everything is fresh and new. All connection settings were copied from the new API on Patreon.

Waiting for this to work again. Everything had been removed and all your instructions followed. This worked once, just waiting for it to work again.

What do you need now to check the webhooks on your end?

Two new posts. Neither automatically imported. A manual import brought the two test posts (now deleted) and the actual post in. A new post this morning hasn’t seen any update. It’s Thanksgiving in the U.S. today, so I won’t be checking again until the late afternoon. My title and content is slightly different, so I’ll wait to see if it auto-imports.

Manual worked, at least yesterday, but I’ll let this one set since I have another post with the content, but with a different title.

This sounds like webhooks are not able to connect to your site from and let your site know about the new post. Either you lost the webhooks in the domain - subdomain delete/reinstall routine, or your site/host is rejecting connections from

You can DM me your creator page url. I can check whether you have valid webhooks recorded on this side.

I DMed you the creator page link in the discord server. Those posts are still not posted. I also posted it here publicly /mattalkonline

Waiting for a reply on the webhook check before I manually sync posts again.

This is the only error recently since the fresh install.

4.98 days ago

fetch_creator_info - API v2 Class - UUID 93df1c52-6ce7-42b7-a5b2-dccbe5da0309 - Response code: 401 Response :{“errors”:[{“code”:1,“code_name”:“Unauthorized”,“detail”:“The server could not verify that you are authorized to access the URL requested. You either supplied the wrong credentials (e.g. a bad password), or your browser doesn’t understand how to supply the credentials required.”,“id”:“93df1c52-6ce7-42b7-a5b2-dccbe5da0309”,“status”:“401”,“title”:“Unauthorized”}]}

That error signifies that your site lost connection to Patreon.

Are you logging in/out of with your creator account while doing these tests or any admin functions?

I haven’t logged in/out since I reconnected. That was the error around the time I did everything you’d asked last week. It’s been a couple of days through the holiday, so I’m not exactly sure the timing if this was before or after.

Waiting on the testing on your end. Haven’t run any sync since.

As we have talked through DM at Discord: In such cases manually importing all posts to get the new posts would work as a workaround. You can temporarily adopt that solution.